Настройка маршрутизатора Cisco.

Вот и к Вам пришел cisco. Задающий тренд телекоммуникаций, самый надежный, вечно живущий и говорящий на своем языке.

Наступило время прикоснуться к нему.

Если это относительно современный девайс, то там будет разъем miniusb, и вам подойдет самый обычный кабель CAB-CONSOLE-USB Cisco консольный кабель USB – mini-USB и драйвер сisco_usbconsole_driver (пройти регистрацию на cisco не помешает, раз уж рещили работать) , если там только порт консоли, то Вам необходим переходник COM 9/25M -> USB AM.

Можно использовать кабель типа Orient < USS-101 (N) > Кабель-переходник USB AM - > COM9M. Ставим драйвер производителя и подключаем.

После установки находим на каком порту появилось устройство и запускаем утилиту putty для windows или linux

И подключаемся.

Во время загрузки, можно видеть все cобытия загрузки операционной системы.

После загрузки устройства должен появиться "wizard" первичной настройки оборудования.

Можно тактично ответить на все вопросы cisco, а можно написать no и продолжить самому.

Далее для тех кто нажал no.

У нас появилось приглашение типа >Router

Мы находимся в консоли роутера. Для начала работы нам необходимо перейти в привелигированный режим вводим команду enable

приглашение измениться на #Router

После этого неплохо будет взглянуть на текущую конфигурацию роутера

show running-config

мы увидим текущую базовую конфигурацию роутера.

Теперь настроим то, что нам необходимо, будем исходить из того, что у Вас один провайдер и есть сеть с потребителями интернет.

Будем пердполагать,что:

адрес интерфейса провайдера 10.69.66.246/27

адрес роутера в локальной сети 10.22.16.2/24

настроим интерфейсы

перейдем в режим конфигурирования

confirure terminal

и зададим параметры интерфейсов

Второй интерфейс FastEthernet0/1 (или GigabitEthernet0/1) - интерфейс локальной сети

настроим его

interface FastEthernet0/1 ip address 10.22.16.1 255.255.255.0

exit

Приступим к настройке авторизации и ssh для нашего маршрутизатора.

Включим шифрование паролей

service password-encryption

Создадим пользователя

username admin privilege 15 secret 1QAz2WSx

пароль должен быть сложнее.

Зададим пароль входа в привелегированный режим

enable secret 1qaZ2wsX

пароль должен быть сложнее.

Задействуем авторизацию aaa

aaa new-model

запишем hostname

hostname R2

и имя домена

ip domain name netbizon.com

установим часы

clock set 6:00:00 18 Jun 2014

Создадим Ключи rsa

crypto key generate rsa

Создадим список доступа для подключения по ssh, telnet

access-list 23 permit 10.22.16.0 0.0.0.255

Настроим интерфейс виртуальной консоли и ограничим доступ двумя протоколами (лучше только ssh)

line vty 0 4

transport input telnet ssh

exit

Задействуем ssh второй версии

ip ssh version 2

Теперь можем подключиться по ssh и продолжить настройки

первый FastEthernet0/0 (У Вас может быть другой например GigabitEthernet0/0, XGigabit 0/0)

interface FastEthernet0/0 ip address 10.69.66.246 255.255.255.224

exit В завершении настроек интерфейса выполним exit выход из настроек интерфейса

Проверим доступность шлюза

ping 10.69.66.254

R2#ping 10.69.66.254 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 10.69.66.254, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/24 ms R2#

Итак шлюз доступен, сделаем 0 маршрут и продолжим сделаем Access-lists

ip route 0.0.0.0 0.0.0.0 10.69.66.254

Это списки, которые будут регламентировать доступ к ресурсам интернет и из интернета к внешнему интерфейсу F0/0 нашего маршрутизатора.

Создадим два ACL

ip access-list extended INTER_OUT evaluate INTER_REF_OUT permit icmp host 10.69.66.246 any reflect INTER_REF_IN permit tcp host 10.69.66.246 any eq www reflect INTER_REF_IN permit tcp host 10.69.66.246 any eq 443 reflect INTER_REF_IN permit udp host 10.69.66.246 any eq ntp reflect INTER_REF_IN deny ip any any log-input ip access-list extended INTER_IN evaluate INTER_REF_IN permit icmp any host 10.69.66.246 echo-reply permit icmp any host 10.69.66.246 time-exceeded permit icmp any host 10.69.66.246 unreachable permit udp host 8.8.8.8 eq domain any permit udp host 4.4.4.4 eq domain any deny ip any any log-input

exit

Как видно из acl, там присутствует директива evaluate и ref

Данная установка позволяет динамически создавать строки в ACL для обратных пакетов.

Применим данные ACL к FastEthernet0/0

interface FastEthernet 0/0 ip access-group INTER_IN in ip access-group INTER_OUT out

exit

Приступим к настройке nat

Создадим ACL для выполнения трансляций

ip access-list extended ACL_NAT_INTERNET permit tcp 10.22.11.0 0.0.0.255 any eq ftp permit tcp 10.22.11.0 0.0.0.255 any eq ftp-data permit icmp 10.22.11.0 0.0.0.255 any permit udp 10.22.11.0 0.0.0.255 any eq ntp permit tcp 10.22.11.0 0.0.0.255 any eq www permit tcp 10.22.11.0 0.0.0.255 any eq 443

exit

Запишем правило source nat

ip nat source list ACL_NAT_INTERNET interface f0/0 overload

Исходящие пакеты будут пересобраны таким образом, что адрес источника (из ACL_NAT_INTERNET) будет заменен адресом внешнего интерфейса.

И теперь нам предстоит включить nat на FastEthernet0/0

interface f0/0 ip nat enable

exit

exit

Сохраним конфигурацию как загрузочную

copy running-config startup-config

На этом настройка роутера завершена.


Featured Posts
Recent Posts
Archive
Search By Tags
Тегов пока нет.
Follow Us
  • Facebook Basic Square
  • Twitter Basic Square
  • Google+ Basic Square
контактная информация

Напишите нам, чтобы получить бесплатную оценку стоимости.

​©  2015 ИП «ИП Примаков В.П.». Сайт сделан на Wix.com

Города, в которых мы работаем с выездом

Наши выездные специалисты с удовольствием помогут Вам в  следующих городах:

Москва

Орел

 

Домодедово

Подольск

Климовск

 

  • Белая иконка Facebook
  • Иконка Twitter с прозрачным фоном
  • google+